May 29, 2024

I was trying to do a yum update and I got this message:

Loading “protectbase” plugin
Loading “priorities” plugin
Setting up Update Process
Setting up repositories
not using ftp, http[s], or file for repos, skipping – 4 is not a valid release or hasnt been released yet
Cannot find a valid baseurl for repo: update
Error: Cannot find a valid baseurl for repo: update

Well, turn out that it’s the [url=http://lists.centos.org/pipermail/centos-announce/2012-February/018462.html]End of life for CentOS4[/url]. Man, not really looking forward to doing an OS reinstall on my forum. But, turns that there is a way to get [url=https://www.centos.org/modules/newbb/viewtopic.php?topic_id=36528&forum=27]yum working again[/url].

In /etc/yum.repos.d/CentOS-Base.repo, comment out the mirrorlist directives and replace with:
baseurl=http://vault.centos.org/4.9/os/$basearch